Java DB - sysinfo (version)

About

The Derby sysinfo tool displays information about your Java environment and your version of Derby.

How to

run it

java -jar %DERBY_HOME%/lib/derbyrun.jar sysinfo
or
sysinfo
or
setEmbeddedCP     -- for the derby_home andclasspath
java org.apache.derby.tools.sysinfo

For the sysinfo tool, issue the command

NetworkServerControl sysinfo
------------------ Java Information ------------------
Java Version:    1.7.0
Java Vendor:     Oracle Corporation
Java home:       C:\Program Files\Java\jre7
Java classpath:  C:\Program Files\Java\jdk1.7.0\db/lib/derbyrun.jar
OS name:         Windows 7
OS architecture: amd64
OS version:      6.1
Java user name:  RIXNI
Java user home:  C:\Users\RIXNI
Java user dir:   C:\Users\RIXNI
java.specification.name: Java Platform API Specification
java.specification.version: 1.7
java.runtime.version: 1.7.0-b147
--------- Derby Information --------
JRE - JDBC: Java SE 6 - JDBC 4.0
[C:\Program Files\Java\jdk1.7.0\db\lib\derby.jar] 10.8.1.2 - (1095077)
[C:\Program Files\Java\jdk1.7.0\db\lib\derbytools.jar] 10.8.1.2 - (1095077)
[C:\Program Files\Java\jdk1.7.0\db\lib\derbynet.jar] 10.8.1.2 - (1095077)
[C:\Program Files\Java\jdk1.7.0\db\lib\derbyclient.jar] 10.8.1.2 - (1095077)
------------------------------------------------------
----------------- Locale Information -----------------
Current Locale :  [English/United States [en_US]]
Found support for locale: [cs]
         version: 10.8.1.2 - (1095077)
Found support for locale: [de_DE]
         version: 10.8.1.2 - (1095077)
Found support for locale: [es]
         version: 10.8.1.2 - (1095077)
Found support for locale: [fr]
         version: 10.8.1.2 - (1095077)
Found support for locale: [hu]
         version: 10.8.1.2 - (1095077)
Found support for locale: [it]
         version: 10.8.1.2 - (1095077)
Found support for locale: [ja_JP]
         version: 10.8.1.2 - (1095077)
Found support for locale: [ko_KR]
         version: 10.8.1.2 - (1095077)
Found support for locale: [pl]
         version: 10.8.1.2 - (1095077)
Found support for locale: [pt_BR]
         version: 10.8.1.2 - (1095077)
Found support for locale: [ru]
         version: 10.8.1.2 - (1095077)
Found support for locale: [zh_CN]
         version: 10.8.1.2 - (1095077)
Found support for locale: [zh_TW]
         version: 10.8.1.2 - (1095077)
------------------------------------------------------

Powered by ComboStrap